Comments: Experiment Guide for the Johnny-Five Inventor's Kit

Pages

Comments 8 comments

  • I just got my tessel 2 and hit an immediate stumbling block because the t2-cli module no longer works with old versions of node, I got a very unhelpful error:

    >t2
    /usr/local/lib/node_modules/t2-cli/bin/tessel-2.js:647
    module.exports.closeFailedCommand = function(status, options = {}) {
                                                                 ^
    
    SyntaxError: Unexpected token =
    ...
    

    Eventually I figured out it was introduced by this change: https://github.com/tessel/t2-cli/commit/847946e3a69e93dbf1ec955e6531e3bcfdb98919

    So I installed t2-cli@0.1.18 and then things worked again.

  • We have t2 -version in the docs when the command is t2 --version

  • Hello! I was doing the experiment on the Magnetic Door Switch with SMS notification (https://learn.sparkfun.com/tutorials/experiment-guide-for-the-johnny-five-inventors-kit/experiment-5-reading-an-spdt-switch) and I had to change a few things to make it work: - The Twilio website has changed a little bit so the screenshots are not completely the same, but no big deal, with the links that are provided it was easy to find what we needed (the SID and Token) - The twilio API has changed and the code in the examples doesn't run anymore. By following this doc: https://www.twilio.com/docs/libraries/node and changing the constructor and the switching the messages.create call to use promises, it works Thanks for your amazing work!

  • When deploying Experiment 10: Using the BME280 I get the following error: `j5ik $ t2 run monitor.js INFO Looking for your Tessel... INFO Connected to willow. INFO Building project. INFO Writing project to RAM on willow (2388.992 kB)... INFO Deployed. INFO Running monitor.js... 1483848840297 Device(s) Tessel 2 (willow)
    module.js:327 throw err; ^

    Error: Cannot find module 'socket.io-client/dist/socket.io.min.js' at Function.Module._resolveFilename (module.js:325:15) at Function.require.resolve (internal/module.js:16:19) at e.serveClient (/tmp/remote-script/node_modules/socket.io/lib/index.js:1:1327) at new e (/tmp/remote-script/node_modules/socket.io/lib/index.js:1:206) at Object.<anonymous> (/tmp/remote-script/monitor.js:16:10) at Module._compile (module.js:409:26) at Object.Module._extensions..js (module.js:416:10) at Module.load (module.js:343:32) at Function.Module._load (module.js:300:12) at Function.Module.runMain (module.js:441:10)`

    I've tried reinstalling socket.io both as instructed and with the -g option but cannot get past the error. There is another post in the forums that mentions the same problem with the Recon bot.

    Thanks,

    Richard

    • Looks like socket.io-client relocated some static file assets which are whitelisted by t2-cli's deployment process. There is a patch to fix this which should land today and a release will follow shortly thereafter (probably also today).

  • -------------------- Tech Support Tips/Troubleshooting/Common Issues --------------------

    Issues Installing Atom Text Editor?

    If you have issues installing the Atom Text Editor [ https://atom.io/ ], you might have issues installing depending on the directory and what permissions you have on the computer [ https://github.com/atom/atom/issues/5767 ]. Try to save the installer in your C:\ drive or on your desktop. Also, make sure that you install as an administrator.

    You can manually install the Atom text editor by following the instructions in the README.md [ https://github.com/atom/atom#windows ] or use a different text editor as stated in the SIK tutorial [ https://learn.sparkfun.com/tutorials/experiment-guide-for-the-johnny-five-inventors-kit/software-installation-and-setup ]:

    You will need a text editor in which to edit and save your JavaScript files. This means a plain text editor, not a Word document. If you’ve already got one, like SublimeText, Notepad++, vim, etc., groovy. If not, go ahead and install Atom.


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!