Digital Sandbox Experiment Guide

Pages
Contributors: jimblom, bri_huang
Favorited Favorite 5

Setting up Arduino and ArduBlock

This page will help you wrangle the computer end of the Digital Sandbox. That process includes downloading and installing the software, installing drivers on you computer, and setting up the Arduino environment to work with your Sandbox. Follow along, and you'll be blinking LEDs in no time!

First things first, you'll need to download some software. There are two options here:

Installing the Custom Arduino IDE

We've packaged up a custom version of the Arduino IDE software (version 1.6.9). This basically includes ArduBlock and the Sandbox examples used throughout this guide. Click one of the links below to download the software for your operating system.

The Arduino software comes packaged in an archived, .zip format. Once you've downloaded the .zip file, you'll need to extract it. Both Windows (use the built-in extract wizard) and Mac (double-click to open) machines should have built-in tools for unzipping.

Windows users should move the folder arduino-1.6.9-SFEardublock to C:\Program Files (x86). Your computer may prompt you with a warning. Windows users can move the Arduino folder to a preferred location, such as “C:\Arduino”. The Sandbox examples are included as well, in a folder named "Digital Sandbox Examples."

Mac users can simply run the Arduino application from the extracted folder, or move it into a preferred directory (e.g. Applications) and then run it.

Mac Custom Arduino with ArduBlock

Once you've installed Arduino, continue on below with installing the Sandbox drivers.

Installing the Arduino Addon

If you already have Arduino installed, you can save some bandwidth and just download the Sandbox addon, which includes ArduBlock, the Digital Sandbox hardware definitions, and the example files. Click the link below to download the Arduino addon folder:

Note: The addon in the link above will only work with Arduino versions 1.6.0 to 1.6.11. If you're using an older version of Arduino (1.0.6 or earlier) download our previous version of the addon instead. The installation directions will be the same.

All of the addon items are archived in a ZIP folder. To install the addon extract the ZIP file into your computer's Arduino sketchbook directory. This is a folder on your computer where your sketches and libraries are saved by default. To find your sketchbook location, run Arduino, and open Preferences by going to File > Preferences. The contents of the top text box defines your sketchbook location. Memorize that location and close Arduino.

Arduino sketchbook location

Then extract the contents of the Sandbox_Addons.zip file into that location.

Directory for Arduino Sketchbook

Installing Drivers

Once you have downloaded and extracted the Arduino software connect the Digital Sandbox to your computer.

Sandbox connected to computer

Once the board is connected, you will need to install drivers. Please go to www.sparkfun.com/ftdi for instructions specific to your operating system.

How to Install FTDI Drivers

June 4, 2013

How to install drivers for the FTDI Basic on Windows, Mac OS X, and Linux.

Open Arduino and ArduBlock

ArduBlock is an add-on that exists inside the Arduino software. To run it, first open the Arduino program. Windows users should run Arduino.exe; Mac users can run the Arduino application.

Open Arduino

Let's do some preparation before opening ArduBlock. First, go to the Tools menu, hover over Board and select Digital Sandbox.

Tools > Board > Digital Sandbox

Next, go back to the Tools menu, hover over Serial Port and select the serial port number that matches your Sandbox board.

Windows serial port selection

  • Windows users: This is likely to be COM2 or higher (COM1 is usually reserved for hardware serial ports). To find out, you can disconnect your Sandbox and re-open the menu; the entry that disappears should be the Sandbox. Reconnect the board and select that serial port.
  • Mac users: On the Mac, this should be something with "/dev/tty.usbmodem" or "/dev/tty.usbserial" in it.

Finally, to open ArduBlock, go to Tools and select ArduBlock.

Tools > ArduBlock

What opens next is the ArduBlock interface. Make sure the Arduino window remains running in the background. If you close that, ArduBlock will close as well.

Example of ArduBlock interface