Installing Arduino IDE

Pages
Contributors: b_e_n
Favorited Favorite 5

Mac

This page will show you how to install and test the Arduino software on a Mac computer running OSX.

  • Go to the Arduino download page and download the latest version of the Arduino software for Mac.
  • When the download is finished, un-zip it and open up the Arduino folder to confirm that yes, there are indeed some files and sub-folders inside. The file structure is important so don’t be moving any files around unless you really know what you’re doing.
  • Power up your Arduino by connecting your Arduino board to your computer with a USB cable (or FTDI connector if you’re using an Arduino pro). You should see the an LED labed ‘ON’ light up. (this diagram shows the placement of the power LED on the UNO).
  • Move the Arduino application into your Applications folder.

FTDI Drivers

If you have an UNO, Mega2560, or Redboard, you shouldn’t need this step, so skip it!

  • For other boards, you will need to install drivers for the FTDI chip on your Arduino.
  • Go to the FTDI website and download the latest version of the drivers.
  • Once you’re done downloading, double click the package and follow the instructions from the installer.
  • Restart your computer after installing the drivers.

Launch and Blink!

After following the appropriate steps for your software install, we are now ready to test your first program with your Arduino board!

  • Launch the Arduino application
  • If you disconnected your board, plug it back in
  • Open the Blink example sketch by going to: File > Examples > 1.Basics > Blink

alt text

  • Select the type of Arduino board you’re using: Tools > Board > your board type

alt text

  • Select the serial port that your Arduino is attached to: Tools > Port > xxxxxx (it’ll probably look something like “/dev/tty.usbmodemfd131” or “/dev/tty.usbserial-131” but probably with a different number)

alt text

  • If you’re not sure which serial device is your Arduino, take a look at the available ports, then unplug your Arduino and look again. The one that disappeared is your Arduino.
  • With your Arduino board connected and the Blink sketch open, press the ‘Upload’ button

alt text

  • After a second, you should see some LEDs flashing on your Arduino, followed by the message ‘Done Uploading’ in the status bar of the Blink sketch.
  • If everything worked, the onboard LED on your Arduino should now be blinking! You just programmed your first Arduino!

Troubleshooting

If you’re having problems, check out this troubleshooting guide from Arduino.