Comments: Installing Arduino IDE

Pages

Comments 3 comments

  • BTW You’ve missed ArduinoCode - Arduino IDE on iOS. With ArduinoCode you can edit with code complete, compile, upload sketches (over USB and BLE) and run serial monitor. http://www.arduinocode.info/p/introduction.html

  • 9/30/14 This goes a little beyond installing just the IDE:

    Just setup 1.0.6 on two ‘different’ computers: my Lenovo W530 with Win7 Pro, and my wife’s W530 with Win8.1 (W530 just purchased ‘lightly used’ from an IT guru at a northeast company who did a fresh restore of 8.0 when we picked it up, which she’s upgraded to 8.1 over the last couple of weeks).

    Mine deleted 1.0.5 as part of the install (which I was not expecting, as my older Sony Vaio with Win Vista never did that, and I have versions going back to -0018 I think, maybe -0022, up to 1.0.5 on that machine). Hers did not have any IDE installed.

    We both then downloaded mighty-1284p that Jack Christensen has taken on maintaining: https://github.com/JChristensen/mighty-1284p The installation directions might suffer from a cut & paste error in step 6:

    1. The following folders and files should now exist: sketchbook\hardware\mighty-1284p\bootloaders

    I don’t think ‘sketchbook’ should be in the path for the list of folders.

    We just have the files in Program Files (x86): Arduino:hardware:mighty-1284P

    Started the IDE, selected Tools:Board:Bobuino. Plugged in a FT232 equipped Bobuino. Selected Tools:Serial Port and picked the new COM port that appeared.

    Opened up blink & downloaded on mine; ran as expected. Opened up blink on hers, changed the time and downloaded; ran as expected.

    Both have 9/16/14 dated files in the Arduino/drivers/FTDI USBDrivers folder.

    Checked the FTDI driver revs: I have 2.8.30.0 from 7/12/2013. I set up my driver last summer when I got the computer. Hers has 2.12.0.0 from 8/26/14. She did not set up any driver, somehow Windows acquired it.

    We did not see any of the unsigned driver issues this article discusses. The install and 1284P addition went smoothly.

    Haven’t tried either machine yet with an Uno or Mega or other 16U2 equipped USB/Serial chip.

  • My W7 does not recognize a new device, why? Is it because of Windows Update? I have also tried a manual instalation of the software, besides the New Hardware Wizard Fails. But when I go to the Device Manger my Arduino board does not appear in the listing that is displayed in COM and LPT…What am I doing wrong?


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!