Installing Arduino IDE

Pages
Contributors: b_e_n
Favorited Favorite 11

Introduction

This tutorial will walk you through downloading, installing, and testing the Arduino software (also known as the Arduino IDE - short for Integrated Development Environment). Before you jump to the page for your operating system, make sure you’ve got all the right equipment.

What you will need:

  • A computer (Windows, Mac, or Linux)
  • An Arduino-compatible microcontroller (anything from this guide should work)
  • A USB A-to-B cable, or another appropriate way to connect your Arduino-compatible microcontroller to your computer (check out this USB buying guide if you’re not sure which cable to get).

alt text

An Arduino Uno

alt text

An A-to-B USB Cable

Suggested Reading

If you’re new to Arduino in general, you want to check out this tutorial to familiarize yourself with everyone’s favorite microcontroller platform.


If you’re ready to get started, click on the link in the column on the left that matches up with your operating system, or you can jump to your operating system here.

Windows

This page will show you how to install and test the Arduino software with a Windows operating system (Windows 8, Windows 7, Vista, and XP).

  • Go to the Arduino download page and download the latest version of the Arduino software for Windows.
  • When the download is finished, un-zip it and open up the Arduino folder to confirm that yes, there are indeed some files and sub-folders inside. The file structure is important so don’t be moving any files around unless you really know what you’re doing.
  • Power up your Arduino by connecting your Arduino board to your computer with a USB cable (or FTDI connector if you’re using an Arduino pro). You should see the an LED labed ‘ON’ light up. (this diagram shows the placement of the power LED on the UNO).

Drivers for Arduino Uno on Windows

Installing the Drivers for the Arduino Uno (from Arduino.cc)

  • Plug in your board and wait for Windows to begin it’s driver installation process
  • After a few moments, the process will fail, despite its best efforts
  • Click on the Start Menu, and open up the Control Panel
  • While in the Control Panel, navigate to System and Security. Next, click on System
  • Once the System window is up, open the Device Manager
  • Look under Ports (COM & LPT). You should see an open port named “Arduino UNO (COMxx)”. If there is no COM & LPT section, look under ‘Other Devices’ for ‘Unknown Device’

alt text

  • Right click on the “Arduino UNO (COMxx)” or “Unknown Device” port and choose the “Update Driver Software” option
  • Next, choose the “Browse my computer for Driver software” option

alt text

  • Finally, navigate to and select the Uno’s driver file, named “ArduinoUNO.inf”, located in the “Drivers” folder of the Arduino Software download (not the “FTDI USB Drivers” sub-directory). If you cannot see the .inf file, it is probably just hidden. You can select the ‘drivers’ folder with the ‘search sub-folders’ option selected instead.
  • Windows will finish up the driver installation from there

For earlier versions of the Arduino boards (e.g. Arduino Duemilanove, Nano, or Diecimila) check out this page for specific directions.

Drivers for RedBoard on Windows

If you are using a RedBoard programmed for Arduino, please go to How to Install FTDI Drivers, for specific instructions on how to install the drivers.

USB Serial Driver Quick Install

August 31, 2017

How to install USB serial drivers on Windows, MacOS , and Linux.

Launch and Blink!

After following the appropriate steps for your software install, we are now ready to test your first program with your Arduino board!

  • Launch the Arduino application
  • If you disconnected your board, plug it back in
  • Open the Blink example sketch by going to: File > Examples > 1.Basics > Blink

alt text

  • Select the type of Arduino board you’re using: Tools > Board > your board type

alt text

  • Select the serial/COM port that your Arduino is attached to: Tools > Port > COMxx

alt text

  • If you’re not sure which serial device is your Arduino, take a look at the available ports, then unplug your Arduino and look again. The one that disappeared is your Arduino.
  • With your Arduino board connected, and the Blink sketch open, press the ‘Upload’ button

alt text

  • After a second, you should see some LEDs flashing on your Arduino, followed by the message ‘Done Uploading’ in the status bar of the Blink sketch.
  • If everything worked, the onboard LED on your Arduino should now be blinking! You just programmed your first Arduino!

Troubleshooting

This guide from Arduino has some more details and troubleshooting tips if you get stuck.

Mac

This page will show you how to install and test the Arduino software on a Mac computer running OSX.

  • Go to the Arduino download page and download the latest version of the Arduino software for Mac.
  • When the download is finished, un-zip it and open up the Arduino folder to confirm that yes, there are indeed some files and sub-folders inside. The file structure is important so don’t be moving any files around unless you really know what you’re doing.
  • Power up your Arduino by connecting your Arduino board to your computer with a USB cable (or FTDI connector if you’re using an Arduino pro). You should see the an LED labed ‘ON’ light up. (this diagram shows the placement of the power LED on the UNO).
  • Move the Arduino application into your Applications folder.

FTDI Drivers

If you have an UNO, Mega2560, or Redboard, you shouldn’t need this step, so skip it!

  • For other boards, you will need to install drivers for the FTDI chip on your Arduino.
  • Go to the FTDI website and download the latest version of the drivers.
  • Once you’re done downloading, double click the package and follow the instructions from the installer.
  • Restart your computer after installing the drivers.

Launch and Blink!

After following the appropriate steps for your software install, we are now ready to test your first program with your Arduino board!

  • Launch the Arduino application
  • If you disconnected your board, plug it back in
  • Open the Blink example sketch by going to: File > Examples > 1.Basics > Blink

alt text

  • Select the type of Arduino board you’re using: Tools > Board > your board type

alt text

  • Select the serial port that your Arduino is attached to: Tools > Port > xxxxxx (it’ll probably look something like “/dev/tty.usbmodemfd131” or “/dev/tty.usbserial-131” but probably with a different number)

alt text

  • If you’re not sure which serial device is your Arduino, take a look at the available ports, then unplug your Arduino and look again. The one that disappeared is your Arduino.
  • With your Arduino board connected and the Blink sketch open, press the ‘Upload’ button

alt text

  • After a second, you should see some LEDs flashing on your Arduino, followed by the message ‘Done Uploading’ in the status bar of the Blink sketch.
  • If everything worked, the onboard LED on your Arduino should now be blinking! You just programmed your first Arduino!

Troubleshooting

If you’re having problems, check out this troubleshooting guide from Arduino.

Linux

If you are a Linux user, you probably know that there are many different distribution ‘flavors’ of Linux out there. Unsurprisingly, installing Arduino is slightly different for many of these distributions. Luckily, the Arduino community has done an excellent job of providing instructions for most of the popular versions. Click on the link below that covers your flavor of Linux:

If the above directions did not work for you, or you don’t see your distribution, try this catch-all guide.

You can go to the download page and download the latest version of Arduino for Linux (there are 32-bit and 64-bit versions available) when your system is properly set up.

Launch and Blink!

After following the appropriate steps for your software install, we are now ready to test your first program with your Arduino board!

  • Launch the Arduino application
  • If you disconnected your board, plug it back in
  • Open the Blink example sketch by going to: File > Examples > 1.Basics > Blink
  • Select the type of Arduino board you’re using: Tools > Board > your board type
  • Select the serial port that your Arduino is attached to: Tools > Port > xxxxxx (it’ll probably look something like “/dev/tty.usbmodemfd131” or “/dev/tty.usbserial-131” but probably with a different number)
  • If you’re not sure which serial device is your Arduino, take a look at the available ports, then unplug your Arduino and look again. The one that disappeared is your Arduino.
  • With your Arduino board connected and the Blink sketch open, press the ‘Upload’ button
  • After a second, you should see some LEDs flashing on your Arduino, followed by the message ‘Done Uploading’ in the status bar of the Blink sketch.
  • If everything worked, the onboard LED on your Arduino should now be blinking! You just programmed your first Arduino!

Troubleshooting

The Arduino Playground Linux section is a great resource for figuring out any problems with your Arduino installation.

Board Add-Ons with Arduino Board Manager

With Arduino v1.6.4+, a new boards manager feature makes it easy to add third-party boards (like the SparkFun Redboard, Digital Sandbox, and RedBot) to the Arduino IDE.

To start, highlight and copy (CTRL + C / CMD + C) the text below for the boards manager URL. You’ll need this to configure Arduino.

https://raw.githubusercontent.com/sparkfun/Arduino_Boards/master/IDE_Board_Manager/package_sparkfun_index.json

Open up Arduino:

  • Configure the Boards Manager
    • For Windows and Linux, head to File>Preferences>Additional Boards Manager URLs and paste (CTRL + V / CMD + V) the link
    • For Macs, head to Arduino>Preferences>Additional Boards Manager URLs and paste (CTRL + V / CMD + V) the link
  • Click on Tools>Board>Boards Manager…
  • Select the Type as “Contributed” from the drop down menu.
  • Click on the SparkFun AVR Boards and then click Install

That’s it! Boards are all installed. This also gives you access to all of our library files as well through the built-in Library Manager tool in Arduino.

Resources and Going Further

Now that you’ve got the Arduino software installed on your system and tested it with your Arduino board successfully, you’re ready for your next steps into the world of embedded electronics.

If you want to learn about some of the concepts that will help you build your projects, check out some of the following tutorials:

If you’d rather jump right in to building something, check out these links to projects here on learn as well as some other places to find Arduino-based projects: