Installing Arduino IDE

Pages
Contributors: b_e_n
Favorited Favorite 5

Linux

If you are a Linux user, you probably know that there are many different distribution ‘flavors’ of Linux out there. Unsurprisingly, installing Arduino is slightly different for many of these distributions. Luckily, the Arduino community has done an excellent job of providing instructions for most of the popular versions. Click on the link below that covers your flavor of Linux:

If the above directions did not work for you, or you don’t see your distribution, try this catch-all guide.

You can go to the download page and download the latest version of Arduino for Linux (there are 32-bit and 64-bit versions available) when your system is properly set up.

Launch and Blink!

After following the appropriate steps for your software install, we are now ready to test your first program with your Arduino board!

  • Launch the Arduino application
  • If you disconnected your board, plug it back in
  • Open the Blink example sketch by going to: File > Examples > 1.Basics > Blink
  • Select the type of Arduino board you’re using: Tools > Board > your board type
  • Select the serial port that your Arduino is attached to: Tools > Port > xxxxxx (it’ll probably look something like “/dev/tty.usbmodemfd131” or “/dev/tty.usbserial-131” but probably with a different number)
  • If you’re not sure which serial device is your Arduino, take a look at the available ports, then unplug your Arduino and look again. The one that disappeared is your Arduino.
  • With your Arduino board connected and the Blink sketch open, press the ‘Upload’ button
  • After a second, you should see some LEDs flashing on your Arduino, followed by the message ‘Done Uploading’ in the status bar of the Blink sketch.
  • If everything worked, the onboard LED on your Arduino should now be blinking! You just programmed your first Arduino!

Troubleshooting

The Arduino Playground Linux section is a great resource for figuring out any problems with your Arduino installation.