Comments: How to Install FTDI Drivers

Pages

Comments 13 comments

  • can someone update this tutorial for windows 10 computers? (I new to using my redboard and I plan on using it to program an attiny85… just cuz…)

  • This helped me resolve an issue I was having getting the Arduino IDE to recognize an Adafruit Feather Huzzah (ESP8266). Thanks for posting!

    https://forums.adafruit.com/viewtopic.php?f=22&t=91868

  • Hi for those who run into trouble after updating to Mac High Sierra. 10.13.0 or higher. Please follow this if your device is not found in the port. On OS X 10.11 or later, another possibility is that VCP has been blocked by installation of D2xxHelper, bundled with an application. VCP and such an application are mutually exclusive. To force using VCP, disable D2xxHelper: cd /Library/Extensions sudo mv D2xxHelper.kext D2xxHelper.disabled Then reboot. To force using D2xx again, rename D2xxHelper.disabled back to D2xxHelper.kext and reboot.

  • Resources and Going Further

    A condensed version of this tutorial can be found here:

  • Can someone please update the FTDI Drivers information for Mac OS Sierra users? I spent the last 4 hours trying to figure out why Arduino won’t upload the code to my Lilypad. I tried 2 different Lilypads, installed and uninstalled the FTDI Drivers, rebooted, read a trillion forum posts and the result is always this error below:

    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding

    I am at total loss on what to do, and have an assignment due on Tuesday. No way i can do anything in this state and am really frustrated :(

    Does someone have any help?

    Thanks

    • Some troubleshooting tips:

      1) Double check your board/port selections in Arduino

      2) Double check your USB cable/try a different cable

      3) Try a different FTDI board (assuming you are using one).

      4) Double check that your board enumerates when you plug it in

      5) Double check what particular driver you are using (looks like there’s potentially a conflict with OS Sierra native drivers and downloaded drivers from this Arduino forum post.)

      6) Email tech support with information about the specific board you are using (and where you purchased it), the version of Arduino, the info that you’re on Mac OS Sierra, and specific troubleshooting steps you’ve taken. The more detailed you can be, the more helpful they can be.

  • On OSX El Capitan the FTDI driver wasn’t loading automatically for me even after unloading the built-in Apple driver. For those with similar problems you can manually load it from the terminal with

    > sudo kextload /Library/Extensions/FTDIUSBSerialDriver.kext
    

    Plug-in your device and then check that it worked. You should see something like

    > ls /dev/*usb* 
    /dev/cu.usbserial-XXXXXXXX  /dev/tty.usbserial-XXXXXXXX
    
  • There are more in depth tutorials on uninstalling and reinstalling drivers from FTDI if you really need => http://www.ftdichip.com/Support/Documents/InstallGuides.htm .

  • If you are on a Mac and not able to see the FTDI in your Arduino IDE’s listed COM ports, you need to install the FTDI drivers for your computer. When opening the iOS’s device manager located in the /Applications/Utilities under the USB tree, the computer was able to see the FTDI. Since the drivers were not installed, the FTDI did not enumerate properly. Try following the tutorial for installing a Mac => https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/mac.

  • If you are using a school computer, you would need to install as an administrator in order to install the FTDI drivers on the computer. There was one case where a customer couldn’t get their FTDI cable working with the school’s Windows 10 OS. The administrator was finally able to get the FTDI working by installing as an administrator on the computer.

  • For users of OS X 10.9+ (Mavericks and later) a detailed description of FTDI driver options can be found here.

  • Yosemite isn’t 10.8, it’s 10.10. That said, on 10.10 these instructions don’t work, and reference an older version of these drivers. My Mac won’t connect to my Redboard no matter what set of instructions I use. Should have bought an UNO.

    • For Yosemite you only need to install drivers for D2XX operations. See http://www.ftdichip.com/Support/Documents/AppNotes/AN_134_FTDI_Drivers_Installation_Guide_for_MAC_OSX.pdf.

      Haven’t used a Redboard myself, there could be a problem if Sparkfun have changed the FTDI chip ID’s. Are you able to see the board in the OS X System Report? It should be under Hardware/USB somewhere. What values are reported for Vendor ID and Product ID?


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!