Comments: Using EAGLE: Schematic

Pages

Comments 26 comments

  • Turn on Layer 93, Pins, to make connecting the net much easier. No guessing where the pins are.

  • What’s the default use for the LEDs attached to PB0, PB1, and PB2? Power and I/O?

  • I noticed that pretty much all of the components listed in the tutorial have a different name in the sparkfun library. Also, there is no ohm value for the 1/4W resistors the tutorial mentions that should be placed.

  • M081X08 8pin 0.1" standard header is now just M08.

  • How do you label individual pins on your header parts?

  • The Connectors library is hosed up too. I can’t add the arduino serial connector or the AVI header… Do you guys test your libraries before you upload them?

    Loading /Applications/EAGLE-6.5.0/lbr/SparkFun-Eagle-Libraries-master/SparkFun-Connectors.lbr …

    Error:

    line 17404, column 10: redefinition of name ‘2X3_SMD’ in tag <package>

    • Sorry about that! That was a merge conflict on our end. If you redownload the libraries, the problem should be fixed now.

  • I’m following the Eagle tutorial and trying to add the power jack to the schematic. I get this error:

    Loading /Applications/EAGLE-6.5.0/SparkFun-Eagle-Libraries-master/SparkFun-Connectors.lbr …

    Error:

    line 17404, column 10: redefinition of name ‘2X3_SMD’ in tag <package>

    Got any ideas for how to fix this?

    • That was a merge conflict on our end. If you redownload the libraries, the problem should be fixed now. Sorry about that!

  • How do I fill in the version and Designed by on the frame shape?

    • You just add some text manually - these aren’t auto-filled fields (check the frame in the Library editor, any auto-filled fields are indicated as “>SOMETHING”.

      If you’d like to make these ‘auto-filled’, you could edit the frame you’re using in the Library editor, add a text like “>VERSION” after the “Version: ” text that’s already there. Then when you use the frame in an actual schematic, go to the Edit menu and choose Global Attributes. Add a new entry, name it “VERSION”, and give it a value of, say 1.0. That version number should now show up in the frame.
      Of course, whether you edit it in Global Attributes or in your schematic directly makes very little practical difference in this usage case.

      • This doesnt work for me. The frame will not update. I tried global attributes CNAME,CREVISION,DESIGNER and VERSION and none of them updates the frame. Even if I say redraw under “view”.

        Any idea? I am using the latest github lib and the latest eagle 7.2.0

        • Seems to work as described for me in eagle 7.2.0 . You mention the use of a github lib, so I’m not sure if you’re modifying an existing design - perhaps some narrowing down of the problem would be of use.

          Start a new schematic. Add the text “>TEST” to the schematic (doesn’t matter which layer). Go to the global attributes dialog, add a new name “TEST” (note, not “>TEST”, but “TEST”) with value “This is a test”. When you click OK in the global attributes dialog, the text in the schematic should update to read “This is a test”.

          • This also works in my schematic. But the frame doesnt update. >Test renamed properly.

            I downloaded the sparkfun eagle parts from their official github repository as described in the tutorial.

            What words are you using as global variable? My eagle is currently set to german language. Should I change this?

            • Ah! Okay, so you are working with an existing part indeed. If you’re using the one from the tutorial, “FRAME-LETTER”, then these values are not set from the global attributes, but from the per-part attributes, as they have been set for the part directly.

              Type the command attribute, or click the icon that looks like a logic gate with “AT” written on it, then click on the frame in the schematic you’re working on. You should then get a dialog where you can modify the values :)

              • Its puts the values on the corner and looks like this: http://i.minus.com/ibzEcBu6akP4BQ.PNG

                I thought it ill place it in the right spot, maybe also in red. Maybe I could use another frame? Or what am i doing wrong?

                • Looks like you’re changing the Anzeige (Display) value - you’ll want to change the Wert (Value) value :)
                  http://i.imgur.com/eL5VW9z.png

                  • Nothing changes. I feel like shit, cannot even handle such a simple thing :D http://i.minus.com/i8Re5Ws1d4Lcb.PNG

                    And now I am using an english system and english eagle. I used FRAME-LETTER Creative commons And this download of the library: https://github.com/sparkfun/SparkFun-Eagle-Libraries

                    • Alright, I’ve created a complete step-by-step, you can check it out there: imgur.com/a/2uMK5

                      One thing that I notice in your screenshot is that your frame doesn’t even read “v01”. So I’m curious when you follow these steps, whether you see any differences from what I’m seeing. Specifically:
                      At Step 7, you should be seeing the attribute fields as shown.
                      At Step 9, you should be seeing the “v01” in your schematic as shown. At Step 15, you should be seeing the “vNico” - but we’ve already established you aren’t, so Step 7 and Step 9 are the ones that interest me most :)

                      As a P.S.: If it still fails, try uploading a test file somewhere, and I’ll have a look at it directly :)

                      • I started with a new project. Step 8 doesnt even display the >DESGINER etc in the frame. I currently cannot upload files but you can use my current PCB, attached in this forum thread: http://forum.arduino.cc/index.php?topic=302996.msg2112741#msg2112741

                        Maybe the current github library has a mistake? Thx for taking the time man!

  • I’ve noticed that in some of the SFE Eagle files, the “stub” net lines on the schematic (those that terminate on 1 componet but are left “hanging” with an implied connection to another net of the same name) terminate with little “flags”.

    A good example of this, are the SCL, SDA, DRDY, ADR1, and ADR0 lines in the schematic for the the TMP006 breakout board. TMP006 PDF Schematic

    How are these little flags created? I looked through the SFE Eagle libraries and couldn’t find an object like this, and I’ve not seen any options in eagle to do this. Are these all created by hand somehow? I really like the approach, as it looks cleaner than just having a line with no endpoint.

    • Those little flags are labels (command: ‘LABEL’, toolset: ‘ABC over ¯\’ icon). You can set it to that little flag style in the top toolbar (look for the icon that looks like that), or in its properties check the ‘XREF’ option, or directly as a command: ‘LABEL XREF’.


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!