Comments: Assembly Guide for SparkFun JetBot AI Kit

Pages

Looking for answers to technical questions?

We welcome your comments and suggestions below. However, if you are looking for solutions to technical questions please see our Technical Assistance page.

  • I'm at a loss with the Example 4 Object Following notebook.

    I keep getting "ERROR: The engine plan file is incompatible with this version of TensorRT, expecting 5.1.6 got 5.0.6, please rebuild.

    I've tried everything including reflashing my sd card with Sparkfun's own Jetbot Image and without doing any updates I still get the same problem.

    I've done everything in your troubleshoot guide and same issue.

    All other examples work.

    What am I missing here with this kit?

    • Hi there, it sounds like you are looking for technical assistance. Please use the link in the banner above, to get started with posting a topic in our forums. Our technical support team will do their best to assist you.

      That being said, as mentioned in the 6. Examples section, that example won't work. For more details, you can read the GitHub issue we link.

  • I recommend you guys include a photo of the config bits on the motor driver. I skimmed the text and missed the config bits, and spent way too much time trying to figure out why none of the peripherals were working (hint - with a config of 0x0, it starts out in UART, and proceeds to spam the I2C bus since it uses the same pins).

  • I'm having issues with the Nano not working with the qwiic system. When I probe the I2C bus it goes super slow. sudo i2cdetect -r -y 2

    I can't seem to do anything with the OLED screen. Using this code with update is_connected just hangs.

    Any recommendations? Is there a step I'm missing to get the qwiic stuff working?

    • There is a background service constantly addressing the OLED to display the IP address and status information. You'll have to stop the service to do anything with the OLED (see the Jetbot GitHub repository).

    • Hmmm, I think we need to get additional information in order to assist you with your issue further. If you could, please consider posting on the SparkFun forums and a Forum Moderator will provide technical assistance shortly.

      Here is a very similar thread that seems to have an identical topic. I suggest you follow the thread and see if there is a resolution for your issues:

      https://forum.sparkfun.com/viewtopic.php?f=159&t=50757&p=207311&hilit=oled#p207311


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!