Comments: Loading Debian (Ubilinux) on the Edison

Pages

Comments 92 comments

  • Folks, This doesn’t seem to be working now at all on Mac OSX or Windows. It looks like the link on the Ubilinux is not delivering the correct archive - not loading for me. See this that I posted on the Intel Communities: https://communities.intel.com/message/338663#338663

  • After trying Ubilinux, I found that I needed to go back to Yocto. If anyone else finds themselves in this position, I wanted to share a discovery that took the pain out of living with Yocto.

    The package installer opkg can install all sorts of common packages, but you need to add a couple of repos.

    This post give the details: https://scivision.co/getting-started-with-intel-edison/

    From the link:

    Add Unofficial Repository
    
    vi /etc/opkg/base-feeds.conf
    and paste in
    
    src/gz all http://repo.opkg.net/edison/repo/all
    src/gz edison http://repo.opkg.net/edison/repo/edison
    src/gz core2-32 http://repo.opkg.net/edison/repo/core2-32
    
    Then hit your Escape key and type
    
    :wq
    
    to exit and save the file ( you forgot how to use vi, didn’t you)
    
    Now I have access to many precompiled programs. The core2-32 directory currently holds the ones you might recognize.
    For example:
    
    opkg update
    opkg install nano
    
    • Thank you for sharing this! If I remember correctly, you used to only be able to use opkg in a cross-compiling situation (e.g. opkg on your desktop before moving the image to the Edison). This helps a lot!

      Edit: That blog post is pretty old. Looks like adding opkg has always been an option. It just didn’t come on the Edison by default.

  • Hey! I can get a long way with this on a new macbook (osx Yosemite 10.10.1) but now I’m stuck.

    I didn’t have homebrew so I install it with:

    $ ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

    Then the script was missing Greadlink. Homebrew provides a coreutils package containing greadlink

    $ brew install coreutils

    Then I was missing gnu-getopt:

    $ brew install gnu-getopt

    Now there is no error the script outputs:

    Using U-Boot target: edison-blank
    Now waiting for dfu device 8087:0a99
        *(I plug the board in and get this...)*
    dfu-util: Device has DFU interface, but has no DFU functional descriptor
    Flashing IFWI
    Flashing U-Boot
    Flashing U-Boot Environment
    Flashing U-Boot Environment Backup and rebooting to apply partiton changes
    Now waiting for dfu device 8087:0a99
    

    Then it’s stuck. Any suggestions?

    • Hi Alx, Thanks for your help on this. One problem, after I do:

      $ ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

      $ brew install coreutils

      $ brew install gnu-getopt

      I then run: sudo apt-get install dfu-util

      when I do this, I get this error:

      apt: invalid flag: -get

      Any thought to why -get isn’t there? Again, thanks for the posts on this

      • You get the error because the “apt” package manager isn’t used on the mac os x. Given that you’ve got homebrew installed, try “brew install dfu-util” to add the package.

    • Can I ask why you needed Homebrew? On the Mac that I used (I must admit, I borrowed a co-workers Mac to do this, as I don’t have one), Homebrew wasn’t needed, as the flashall.sh script just worked.

      • So no one gets confused by this comment - The Mac did have homebrew. :) Please see comments below for more information. Thanks!

      • Hey Shawn!

        About half way across line 8 of the flashall.sh script it says “$(brew list gnu-getopt | grep bin/getopt)” which checks that gnu-getopt has been installed with homebrew I think. When I ran the script without homebrew and gnu-getopt there was an error.

        Thanks for all the tutorials and help, I’m really excited about the Edison!

        • Hi Alx! Sorry for responding late here! Just came back from vacation, so very sorry for any inconvenience. Doesn’t appear to be compatible with Mac OSX. I recommend Linux or Windows. You can also use VirtualBox or VMware. The OSX isn’t properly detecting the dfu device. When you manually enter dfu mode (to do this hit any key while booting, which stops the boot. That allows you to enter into dfu mode) and attempted to flash the image it still fails. Which, at this point is a rabbit hole on what is wrong. I have ensured I have the latest brew packages. (Have dfu-util 0.8, which is perfectly fine) Shawn - can you update the tutorial to reflect Mac users to use VirtualBox for now, since there is a lot of reasons why this is happening and Ubilinux recommends Linux or Windows for the loading debian on the Edison? Thanks!

        • Alx,

          I’m having trouble re-producing the error. I’ve sent it to someone who is much more of a Mac person than I am, so I’ll let you know if she can figure it out. Thanks for letting me know about the error!

  • Emutex is no longer hosting ubilinux. Does anyone happen to have a copy or can point to a mirror?

  • bboyho / last year / 1

    ——————– Tech Support Tips/Troubleshooting/Common Issues ——————–

    When loading Ubilinux on the Edison and the process skips rootfs, try looking at this forum post in the Intel Edison Forums with Joakim’s answer => https://communities.intel.com/message/276396#276396

  • I have OS X mavericks and was able to get it to work using instructions from here http://www.emutexlabs.com/ubilinux/29-ubilinux/218-ubilinux-installation-instructions-for-intel-edison

    So far as I can tell the key is to connect to both J3 and J16 usb ports. Seems too simple, but it worked.

    Cheers,

    Thomas

  • Using Ubuntu 14.04, I get a lot of hang ups on screen /dev/ttyUSB0 115200 ; I have logged in successfully, but have been unable to move much further than that. The proxy command line from Screen will become unresponsive (except for the fact tat i can properly kill the terminal). Any suggestions?

    • I would suggest re-flashing the Edison. If you can, try going back to the original Edison Yocto image and see if you can log in over the USB. Once you verify that, try flashing Ubilinux again.

  • Hello all,

    How can I enable auto-login for the root user? I want start up a program as long as the ubilinux boot is completed, I tried this:

    As root, edit the file /etc/inittab. Find a line that looks something like the following:

    1:1235:respawn:/sbin/agetty 38400 tty1 linux Replace that line with (or better yet, comment it out and add) one which reads as follows:

    1:1235:respawn:/sbin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1

    However, it is not working. After a while Edison reboots. Do you have any idea what is the problem?

  • Unable to connect to WiFi network after loading Ubilinux. As a reference, WiFi was working as expected under the Yocto installation. When I run the ifup wlan0 command I get a message stating “No DHCPOFFERS received.”

    Running ifconfig shows wlan0 with no inet addr but it does show an inet 6 address.

    Running iwconfig shows ESSID as “off/any” and Encryption key as “off”

    My interfaces file has the following contents:

    interfaces(5) file used by ifup(8) and ifdown(8)

    auto lo iface lo inet loopback

    auto usb0

    iface usb0 inet static address 192.168.2.XX netmask 255.255.255.0

    auto wlan0 iface wlan0 inet dhcp # For WPA wpa-ssid “A…………Z” wpa-psk c9………..4e10fe05 # For WEP #wireless-essid Emutex #wireless-mode Managed #wireless-key s:password

    And the following 4 lines are for when using hostapd…

    Any help would be greatly appreciated. Thank you.

    • How many characters long is your wpa-psk? You are definitely running WPA (not WEP) on your network? You could also try temporarily disabling IPv6 on the Edison to see if that helps: http://ask.xmodulo.com/disable-ipv6-linux.html

      • Yes, definitely running WPA on my network. In your section on enabling WiFi, I reverted back to the quick and dirty way and used the 11 character password, in plain text. I also tried your suggestion to disable IPv6 - all to no avail.

        I’ve reflashed the image 3 times and spent several hours browsing the internet for a solution.

        As I mentioned in my first comment, wifi on the latest Yocto image works very well, so I believe I have the issue narrowed down to Ubilinux.

        • Also, try the wpa-ssid without quotes. That seems to affect things.

        • Really strange. I haven’t had an issue with WiFi. Can you give me the output of uname -a? I’m wondering if it’s a problem with the version of Ubilinux.

          • I did try the wpa-ssid without quotes - no success in connecting to wifi.

            Here is the output of ‘uname -a’:

            root@ubilinux:~# uname -a Linux ubilinux 3.10.17-yocto-standard-r2 #7 SMP PREEMPT Thu Feb 26 09:57:06 UTC 2015 i686 GNU/Linux root@ubilinux:~#

            Here is the output of restarting wlan0:

            root@ubilinux:~# ifup wlan0 Internet Systems Consortium DHCP Client 4.2.2 Copyright 2004-2011 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/

            Listening on LPF/wlan0/78:4b:87:a5:b0:2a Sending on LPF/wlan0/78:4b:87:a5:b0:2a Sending on Socket/fallback DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13 DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2 No DHCPOFFERS received. No working leases in persistent database - sleeping. root@ubilinux:~#

            • That is the same version of Ubilinux that I’m using on my Edison right now. It looks like you are correctly requesting an IP address on your network, but your router is not liking the requests. Is there another wireless network you could try? Additionally, take a look at some sites like this one that offer some fixes to the “No DHCPOFFERS received” problem.

  • Hello,

    I tried to load Ubilinux on the Edison but there are some issues. After the place where it says “flashing rootfs…” , the download completes and the cmd prompt immediately closes. Is it supposed to say “U-boot & Kernel System Flash Success… Your board needs to reboot to complete the flashing procedure, please do not unplug it for 2 minutes.” ? After this , When I connect my other USB cable , it does not show up on device manager under ‘ports’ and remains disconnected. In fact ‘ports’ itself remains hidden. How can I fix this ? Thanks !

    • It sounds like the flashing process failed. It won’t give you an error message - it will just exit and close the window prematurely. I would try it again a few more times to see if it works. It is supposed to say “U-boot & Kernel System Flash Success…” but you may not see it if the window closes too quickly. I recommend trying to run the .bat script from a command window (e.g. open up Command Prompt, cd to your Ubilinux directoy, and run “flashall.bat”). That way, you can watch the output more carefully. See if that works.

  • Hi, after switching to ubilinux I’ve lost wifi. Set up the wifi configuration files properly but I can’t see the interface, and

    root@ubilinux:~# ifup wlan0
    wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    Cannot find device "wlan0"
    Bind socket to interface: No such device
    Failed to bring up wlan0.
    root@ubilinux:~#
    

    Also, dmesg shows errors loading the modules (bcm4334x is the wifi module)

    Loading kernel module bcm_bt_lpm.
    libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.10.17-poky-edison+/modules.dep.bin'
    [info] Loading kernel module bcm4334x.
    libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file     '/lib/modules/3.10.17-poky-edison+/modules.dep.bin'
    

    Why is ubilinux trying to load poky modules? There is a 1 month old post in the Emutex forum with 0 responses… support seems flaky. Anybody else got this error? You people managed to get wlan0 up?

    • Weird. WiFi worked for me for the versions of Ubilinux that I’ve installed. What version are you using? Could you post your /etc/network/interfaces file (remove and sensitive information, like your WiFi password)? I see that you are using wpa_supplicant. Are you able to connect without it?

      • Ok, I just flashed ubilinux over again a couple of times and found out that I got a different count of ‘#####’ each time, so I guess it was that the flashing was being interrupted and it didn’t flash the entire image. There should be some mechanism to tell that flashing failed. Anyway now its working.

  • At first the flashall script failed on OSX Yosemite as it could not find lsusb. I installed lsusb using the instructions here:

    brew update             && \
    brew tap jlhonora/lsusb && \
    brew install lsusb
    

    I’m currently stuck because booting fails on:

    can't stat '/home/root': No such file or directory
    
    • It seems that flashing did not go ok. While booting I could put my edison in flash mode again. Than I made a small change to the flashall.sh script and tried again. Everything is working fine now.

      This gist helped me out with the necessary changes to flashall.sh.

      Given these notes the steps in the article seem perfectly fine to install ubilinux on an edison using a Mac with OSX Yosemite (10.10.2).

  • no errors but when i log in through my sparkfun base block it still says

    Poky (Yocto Project Reference Distro) 1.6.1
    

    Running on osx 10.9.5

    sudo ./flashall.sh
    Using U-Boot target: edison-blankcdc
    Now waiting for dfu device 8087:0a99
    Please plug and reboot the board
    dfu-util: Device has DFU interface, but has no DFU functional descriptor
    Flashing IFWI
    dfu-util: Device has DFU interface, but has no DFU functional descriptor
    Download    [=========================] 100%      4194304 bytes
    Flashing U-Boot
    Download    [=========================] 100%       245760 bytes
    Flashing U-Boot Environment
    Download    [=========================] 100%        65536 bytes
    Flashing U-Boot Environment Backup
    Download    [=========================] 100%        65536 bytes
    Rebooting to apply partition changes
    Now waiting for dfu device 8087:0a99
    dfu-util: Device has DFU interface, but has no DFU functional descriptor
    Flashing boot partition (kernel)
    Flashing rootfs, (it can take up to 10 minutes... Please be patient)
    Rebooting
    U-boot & Kernel System Flash Success...
    Your board needs to reboot to complete the flashing procedure, please do not unplug it for 2 minutes.
    
    • It definitely seems like the flashing process worked. What operating system are you using?

      • sorry i removed my post coudlnt get the formatting correct. osx 10.9.5

        • I got mine to flash on 10.10, but it hangs on boot. Take a look at BrentBoron’s post below. He modified the flashall.sh and got it to work with 10.9.

          I’m still trying to figure out a solid flashing method from OS X. I have a question out to the EmutexLabs people now.

  • Hi, I am trying to log into the edison from my mac (yosemite). I get one of three errors when I enter the screen /dev/tty….115200 command:

    The first is a blank screen

    The second is an error - Cannot open line screen /dev/tty….115200. Then Sorry couldn’t find a PTY. Both of these flash on the screen briefly.

    The third is an error “Reached target Rescue Mode” This last one happens after it looks like ubilinux starts up. There is also an output that says [FAILED] Load Kernel Modules.

    I am not sure what has happened, maybe the install did not work properly. Any ideas/help would be greatly appreciated.

    • If you get the “Cannot open line screen error,” that means that you’re not communicating with the FTDI chip. The Edison can be powered down, and as long as you have a USB cable connected to the FTDI , you should be able to open a screen terminal. Are you using the Arduino, Mini, or Base Block with the Edison?

      As for the “Reached target Rescue Mode,” that seems a bit worse. I had my Edison working from Yosemite yesterday (I’m not a Mac person, so I had to borrow one). However, it now appears to be hitting that same error. I’ll need to look into it more (I’ll make a note on the tutorial under the OS X part). In the meantime, do you have another OS available that you could try the flashing process from?

      • I am using the baseblock with the edison (I brought the starter kit).

        I pulled apart the kit just to have the edison and the base block. I have been trying to get it going on my mates linux (ubuntu) but it still wont boot past “Reached target rescue mode”. The first two errors are fine now.

        We have been trying to reflash it off his linux but that is not working. noname@X220 ~/Downloads/toFlash % sudo ./flashall.sh 16:35:34 Using U-Boot target: edison-blankcdc Now waiting for dfu device 8087:0a99 Please plug and reboot the board (WE PLUG IN THE BOARD HERE BUT NOTHING HAPPENS UNTIL THE TIME OUT) Timed out while waiting for dfu device 8087:0a99 DEBUG: lsusb Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 005: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP) Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1) Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub DEBUG: dfu-util -l dfu-util 0.5

        © 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc. © 2010-2011 Tormod Volden (DfuSe support) This program is Free Software and has ABSOLUTELY NO WARRANTY

        dfu-util does currently only support DFU version 1.0

        Found Runtime: [0a5c:217f] devnum=0, cfg=1, intf=3, alt=0, name=“UNDEFINED” Did you plug and reboot your board? If yes, please try a recovery by calling this script with the –recovery option [1] 22100 exit 254 sudo ./flashall.sh

        We are out of ideas atm so any advice would be greatly appreciated.

        • I don’t have my Edison to try anything at the moment, but I’m starting to suspect something wrong with dfu-util. Did you install dfu-util, or are you using the version that came with Ubuntu?

  • If I install Ubilinux on my Edison can I still able to write programs for the GPIOs, PWMs, Serial, I2C, SPI busses?? Is there a lot of work to do to get them setup?

    Thanks,

    Jay

    • I found the answer to my question in the “resources and going further” section. It shows how to setup libmraa and access all of the good stuff.

  • Hi, How can i setup kernel headers for edison 3.10.17-poky-edison-ww42+ in Ubilinux?

  • Hi Shawn, Thanks for the great tutorial! Assuming the last comments from hello-techie are still accurate (below), any chance you could update the tutorial to reflect that this doesn’t really work on Mac OSX? It’s easy to spend a couple of days in the OSX-update/add-package cycle trying to figure out why it doesn’t work per the tutorial… Unless of course, someone has figured out a new flashall.sh for OSX (which would also be cool!). I’m headed to one of the old Windows machines in the meantime. Thanks again! (Using Mac OSX 10.9.5, btw)

    • Shawn, I withdraw the request above. By creatively modifying the flashall.sh script and downloading a few different packages I was able to get this to work on a Mac (my windows machine was too down level…). Thanks again for an excellent tutorial!

      • That’s great news! Do you have what changes you made? I would very much like to add it to the tutorial (I would give you credit, of course).

        • Had to try this on another Mac to make sure I remembered what I did…

          First thing I had to so was load a dfu-util on the Mac. I found a method (look section 3 about dfu-util in the OSX section about OpenMoko Flasher) to add dfu-util without having to add a lot of other package managers to make the installation work. Basically, you add the OpenMoko Flasher package (which is a free download - I got a copy from CNET download.com) and create an alias to the location of dfu-util included in OpenMoko Flasher. I created a symbolic link in the toFlash directory I did my install from.

          This version of dfu-util does not list a version number when it is run or queried, so I’m not sure what the actual version is. It does work however, although it is extremely slow. The flash / download takes about 55 to 60 minutes on my machines using this dfu-util version. It’s possible that there are versions that are faster than this, but this is the one I’ve used twice with good success.

          I should also mention both of these Macs have Xcode 6.1.1 installed with all of the command line tool options. I don’t know if this is necessary or not, but there are several references to needing the command line tool option installed in various forums and comments.

          Further, I modified the flashall.sh script to hard code a few variables to remove dependencies on uninstalled package managers to function properly. The changed lines are as follows (at the top of the script)…

          #GETOPTS=“$(which get opt)”

          #if [[ “$OSTYPE” == “darwin”* ]] ; then READLINK=greadlink; GETOPTS=“$(brew list gnu-getopt | grep bin/getopt)”; else READLINK=readlink;fi;

          #BASE_DIR=“$(dirname $0)”

          BASE_DIR=“$(pwd)”

          ESC_BASE_DIR=${BASE_DIR/‘ ’/‘\ ’}

          Then, further down the script:

          function flash-command-try {

          eval ${BASE_DIR}/dfu-util -v -d ${USB_VID}:${USB_PID} $@ $OUTPUT_LOG_CMD

          }

          and,

          function flash-debug {

          lsusb

          ${BASE_DIR}/dfu-util -l

          }

          And a little further down, comment everything out between the top execute getopt comment, and done:

          ## Execute old getopt to have long options support

          #ARGS=$($GETOPTS -o hvlt:eidb -l “keep-data,recovery,help” -n “${0##*/}” – “$@”);

          ##Bad arguments

          #if [ $? -ne 0 ]; then print-usage ; fi;

          #eval set – “$ARGS”;

          #while true; do

          # case “$1” in

          # -l) shift; DO_LIST_VARIANTS=1;;

          # -t) shift; if [ -n “$1” ]; then VARIANT_NAME=$1; shift; fi;;

          # -h|–help) shift; print-usage;;

          # -v) shift; OUTPUT_LOG_CMD=“ 2>&1 | tee -a ${LOG_FILENAME}”;;

          # -i) shift; DO_RECOVERY=1;;

          # -d) shift; DO_DFU_FLASH=1;;

          # -b) shift; DO_RECOVERY=1; DO_DFU_FLASH=1; VARIANT_NAME=$VARIANT_NAME_BLANK;;

          # –recovery) shift; DO_RECOVERY=1;DO_DFU_FLASH=0;;

          # –keep-data) shift; DO_RECOVERY=0; VARIANT_NAME=$VARIANT_NAME_DEFAULT;;

          # –) shift; break;;

          # esac

          #done

          That’s about it. As mentioned, I just tried this with my other Edison on a clean Mac (OSX 10.9.5) to verify it would work again. Feel free to clean this up and use it as you wish.

  • Hi, I would like to know how to go back to Yocto? Most of the tutorials here and on instructables use commands not available on ubilinux. I read below that simply by executing flashall.sh, however if I run it, plug my edison, and leave it for around 5-10 minutes, I come back to ubilinux. Yes, I made sure i’m using the yocto image, actually downloaded it multiple times to be sure. I have tried flashing it on both windows and ubuntu, to no avail. Some help would be nice. If you need pictures about anything, be it terminal logs or something, let me know.

  • I also think this bricked my Edison … Waited about 10 minutes after the script finished. (noticed the edison rebooted a couple of times). I could kind off connect to the serial monitor only to see it was stuck at “Reached target Rescue Mode.”. Tried reformatting / partitioning it but it only shows one 534.8 MB partition. Any idea if I can get this back up and running ? P.S. : I would put the disclaimer about bricking it in bold red and a slightly bigger font :) (Using Mac OS X 10.9.4)

    • FYI : here’s the boot sequence that I see when i attach a serial monitor : Is there a way to recover from this ?

      • I’ve been unable to brick my Edison (I’ve tried pulling power in the middle of the flashing process and right at the end), so I can’t replicate the problem. I see you have posted on Intel’s forum, and that is probably the best place to watch right now. If I come across any other information, I will let you know (and update the guide as well).

        • Yes I’ve posted on that forum as well … I can interrupt the autoboot process , no idea if there’s something I can do on that level ?

          • FYI : If you interrupt the boot sequence (hit enter) and type “run do_flash” it puts the Edison back in DFU mode, allowing you to execute a flashAll.sh again (back to stock Yocto). big thanks to Joakim on the Intel forum for that.

            • Thank you so much! I added this solution to the troubleshooting section and pointed readers to it in the introduction.

              • Excellent …. hope it helps other users…. Looking forward to playing around with it this weekend. And great to see you guys supporting it with the tutorials and various packs / blocks….

  • I’m curious if there’s a way to go back to yocto. Is it as easy as updating yocto as described in the “Getting Started Guide”?

    • It’s actually closer to how you flashed Ubilinux in this guide. If you download the “Edison Yocto Complete Image” from Intel’s site, you will see a “flashall.bat” and “flashall.sh” script in the zip file. That will allow you to flash the Edison with Intel’s Yocto image.

  • This tutorial was fantastic! My next question though is how to implement bluetooth. I need to pair a PS4 controller but not sure how to do it. Any suggestions?

    • I have not tried Bluetooth on the Edison yet, but I imagine it is similar between Yocto and Ubilinux. I recommend checking out Intel’s documentation. They have a guide dealing with Bluetooth, so I recommend starting there.

      • I was able to pair when I had yocto and followed the documentation, but I haven’t been able to with Ubilinux. I’ll just keep trying till I figure it out or read somewhere how to do it. But it would be a great followup article! :)

  • Hi, I’m stuck when you ask to run flashball.bat. I get the following:

    The program can’t start because libusb-1.0.dll is missing from your computer. Try reinstalling the program to fix this problem. I can’t find any version of this driver for Windows. I tried libsub-win32 but it does not seem to change anything.

    Thanks

  • I was stuck on the Ubilinux installation procedure, where Windows flashall.bat invokes dfu_util, which emits 3 error messages and doesn’t download anything. The errors are: Device has DFU interface, but has no DFU functional descriptor Same error, 3 times. Then the Edison proceeds to boot the default Yocto (seen on the putty console).

    I found the problem is my Windows system is missing the Intel driver set, available at: https://communities.intel.com/docs/DOC-23242 , select Windows Driver setup 1.0. Just run it. Includes RNDIS (remote network driver), Composite Device Class, & DFU. Then unplug and replug the Edison once, to allow Windows to match and load the driver. I did unplug and replug a second time.

    Now go back and reinvoke flashall.bat, and “Dfu device found” shows in the cmd window, and it proceeds to download stuff…as below. Your Tutorial should mention installing the Intel drivers!!

    Using U-boot target: edison-blank Now waiting for dfu device 8087:0a99 Please plug and reboot the board Dfu device found Flashing IFWI Download [=========================] 100% 4194304 bytes Download done. Download [=========================] 100% 4194304 bytes Download done. Flashing U-Boot Download [=========================] 100% 245760 bytes Download done. Flashing U-Boot Environment Download [=========================] 100% 65536 bytes Download done. Flashing U-Boot Environment Backup Download [=========================] 100% 65536 bytes Download done. Dfu device found Flashing boot partition (kernel) Download [=========================] 100% 5816320 bytes Download done. Flashing rootfs, (it can take up to 5 minutes… Please be patient) Download [====================== ] 88% 1426063360 bytes

    • I’m having this same issue and yet I’ve installed the drivers. COM3 is working fine… the EDISON disk is working fine….

      I’m running windows 8.1 latest and just hit a wall.

    • Thanks for catching that. I’ve added a part about installing the Edison drivers on Windows.

  • Maybe this is a dumb question, but how does one go about properly shutting an Edison down? Specifically with Ubilinux, the shutdown command does not work/exist…

  • I’m having the same issue that Alx and GaryiOS are having with OS-X Yosemite.

  • THANKS FOR BRICKING MY EDISON, WHY POST A GUIDE THAT CAN DESTROY THE DEVICE?

    • After playing with putty a bit, I was able to find out it’s the kernel immage that won’t load. the device is still in dfu but there is no driver to do a flashall. putty is stuck trying to autoboot, once canceled it still has the option to enter a boot command. Any idea how to load the kernel image, or get it back to stock and out of dfu?

      • I tried using the instructions as they are written. The part about walking a for a few minutes was my error! Why would you recommend for people to walk away , when they return there is no way to know if it finished! i waited till the next morning to unplug it. I still think it was a bad idea to post this when there is no way to know when its done and no way to cancel it or reflash to stock. After going to Intel’s forum, I’m not the only one this happened to and there is no fix as of yet. p.s. its a Lenovo ultrabook, running windows 8

        • I completely agree. I did not write the flash script, so I would write the Intel/Ubilinux people about that. That is how they provided the flash script.

          Can you get any sort of POST in PuTTY? If so, could you paste what you see? Specifically, I’m looking for the part that says “*** Ready to receive application ***”

          • It showed up as a uart FTDI connection, When at the “ Ready to receive application ” running the run do-flash command but rescue mode was corrupted do to the corrupt kernel (which has something to do with windows 8 or the Lenovo, I think windows antivirus or firewall blocked or hung up something corrupting it) I had to use xfst and change the device id in the flashall.sh file, while quickly hitting the reset button, just to fix recovery mode or rescue mode which ever it is. I had to spend $30 to get a hard drive to run linux on since xfst only works on 32bit linux (not happy about that at all). Once it was fixed it allowed the flashall.sh in the terminal. It is impossible to fix with windows.

            • There are several people on Intel’s forum with this same problem from this guide, I’m very surprised you can’t replicate the issue. The install process completely finished on mine it restarted twice and I even left it plugged in over night (just cause I’m lazy and feel asleep with it plugged in), that’s why I think windows 8 corrupted it. It was definitely the kernel being corrupted.

              • I walked someone through the install process of Ubilinux on Windows 8 yesterday, and it worked fine. What version of 8 are you on? Are you using 8.1?

    • Rather than post in all caps, could you give a bit more detail about what happened so we could help you?

  • Anyone else receive the following error when attempting to run flashall.sh in Ubuntu 14?

    ./flashall.sh: line 120: dfu-util: command not found

    I’m getting this error repeatedly during the execution of the script.

    Thanks


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!