Comments: ESP32 Thing Plus Hookup Guide


Looking for answers to technical questions?

We welcome your comments and suggestions below. However, if you are looking for solutions to technical questions please see our Technical Assistance page.

  • Member #1482362 / about 3 years ago / 2

    For the Thing WROOM, I had to press the '0' button on the board after I the Connect ....____ appears, and release it once it connects. otherwise it does not connect.

    Unfortunately, I have to do this every single time I upload.

    • Hi There, Please double-check that you are using the latest driver on the CP210X. If you use an old one (or the one that windows automatically installs), then the auto-reset does not work. See this drivers section of the tutorial for more info and links.

      Hope this helps!

  • Member #1740873 / about 2 years ago / 1

    Quick note for Linux users. You don't appear to need to install the SiLabs USB driver - the serial driver provided through pyserial seems (thus far?) to work fine. python3 -m pip install pyserial

    I did have to adjust permissions to enable the IDE to access the USB serial port though:

  • Member #326200 / about 2 years ago / 1

    Over here: It claims the I/O when used in digital mode is 5V tolerant–and allegedly it is confirmed by the Espressif CEO! Does this seem accurate, or is there something about the spark fun board that would make this not hold up?

  • Member #1536123 / about 2 years ago / 1

    Is there a trick to achieving the 2.5uA deep sleep current? I'm getting about 280uA, using this code to go to sleep:


    I'd love to go even lower.

  • Santafen / about 3 years ago / 1

    I cannot get this device to connect to WiFi no matter what I do. I run the exact same code on it that I run on my Adafruit ESP32s, yet it never connects.

    I even ran just the Basic WiFi Example from Sparkfun, yet no joy. Just prints ..... infinitely while waiting for WL_CONNECTED. And yes, the SSID and password are correct. :-)

    Any ideas?

  • Member #533342 / about 3 years ago / 1

    What are the GPIO pin numbers of the SDA/SCL pins on the Qwiic connector, and is it I2C_NUM_0 or I2C_NUM_1?

If you've found an issue with this tutorial content, please send us your feedback!