Comments: Qwiic Scale Hookup Guide


Looking for answers to technical questions?

We welcome your comments and suggestions below. However, if you are looking for solutions to technical questions please see our Technical Assistance page.

  • Member #1387058 / about 2 years ago * / 1

    I see in the datasheet that the NAU7802 chips all have the same hard-set address. I'm trying to make a qwiic mux board work, but so far not having much luck with modifying the example code for it. I am using a Thing Plus ESP32 WROOM C for my MCU and have the mux board connected to it on one of the main ports and the two quick scale boards connected to it on addresses 0 and 1. I have the for loops for selecting each board in sequence in the proper places in the qwiicScale code, the Mux Control in the same folder, but still no luck. It seems to die at Wire.begin(). I need to use two of these off of one MCU, and cannot use the second channel because of wire length and noise getting in on the second load cell.

  • Member #1727944 / about 2 years ago * / 1

    Love this guide! One issue I seem to be having, after loading up example 2 and calibrating the scale with a known weight, LOCATION_CALIBRATION_FACTOR and settingCalibrationFactor don't seem to save to EEPROM. It always reverts back to "default" values of "Calibration factor: 1.97", "Zero offset: 1073484120" after rebooting, giving an inaccurate reading. This forces a recalibration after every reboot. Not entirely helpful!

  • Alright, where's the library & guide for the pi?

  • Member #1180974 / about 4 years ago * / 1

    Edit2: Sorry about everything below. My problem was with Platformio. It wants functions to be declared at the top of the code, and Arduino IDE puts them at the bottom. Sorry again.

    I successfully ran the Example1_BasicReadings example code, and got numbers from the Quiic Scale. But when I try to compile Example2_CompleteScale, I get compile errors on readSystemSettings, calibrateScale, and recordSystemSettings. I don't see these functions declared in the .h file. I must be missing a file, but where can I find it? Edit: My problem showed up when I used VS Code with Platformio. I just tried it with the Arduino IDE, and it compiled. So the problem seems to be with Platformio. Any ideas about that would still be appreciated.

    • santaimpersonator / about 4 years ago / 1

      Hi there, it sounds like you are looking for technical assistance. Please use the link in the banner above, to get started with posting a topic in our forums. Our technical support team will do their best to assist you.

      That being said, the utilization of is probably outside the scope of our support team.

If you've found an issue with this tutorial content, please send us your feedback!