Comments: MaKey MaKey Advanced Guide


Looking for answers to technical questions?

We welcome your comments and suggestions below. However, if you are looking for solutions to technical questions please see our Technical Assistance page.

  • Member #550668 / about 10 years ago / 2

    Thanks for maintaining this guide. Just wanted to comment that I created a peer-based MOOC on P2PU for additional MaKey reprogramming exercises and peer support here:

    Part of the course links users back to the MaKey guides here.

  • TomKeddie / about 8 years ago / 1

    is this process still supported with the move to using the PIC processor on MakeyMakey?

    • M-Short / about 8 years ago / 2

      I believe JoyLabz now uses a PIC on their boards, but our design hasn't changed so this should all still be accurate.

  • Member #671545 / about 9 years ago / 1

    i can detect as make-makey but cannot upload me...i need it fast

  • -------------------- Tech Support Tips/Troubleshooting/Common Issues --------------------

    Makey Makey from JoyLabz

    If you go to your device manager and the board is showing up as an Arduino Leonardo, it's probably from JoyLabz. They have a different driver than ours => This is probably why certain boards that are not manufactured at SparkFun are not able to use our drivers from out tutorials.

    However, there was a customer that got a similar message like that and tried to upload code to the board:

     Found programmer: Id = "SÙ"; type = p
     Software Version = V.
     avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?

    Another customer responded with this:

     I also got my Makey Makey from Joylabz (Sorry Sparkfun, I didn’t notice you were selling it :( ) and had this issue. Here is what I did to solve it:
     1) Remove any drivers you have for the device already
     2) Windows will recognize the device as an Arduino Leonardo. Update the drivers and point it to your Arduino folder.. for me /arduino01.0.3/drivers
     3) Windows will install the Arduino Leonardo drivers and set it to an available comport.
     4) Open your arduino IDE and the Makey Makey source file from sparkfun.
     5) Make sure you have Tools->Board selected as Arduino Leonardo and also Tools->Serial Port selected to the appropriate COM Port
     6) Open Device manager, get the Arduino IDE and your device manager on the same screen so you can see them both
     7) Attempt to upload to the makey makey (The right arrow button)
     8) Watch closely in your device manager, you will see the Arduino Leonardo disappear and briefly the Makey Makey will appear under your unknown devices implying it has no drivers. You need to click on it fast to catch it and select “Update Drivers”
     9) Direct the driver selection to the location where you stored your sparkfun makey makey driver. For me this is /Documents/Arduino/hardware/MakeyMakey/driver
     10) It will attempt to install the driver but most likely say it failed in the end because it didn’t have enough time
     11) Wait for the Arduino IDE to fail again, then try reprogramming, possibly one more time if needed.
     12) Bask in the sweet joy of seeing “Done Uploading” and enjoy your makey makey
     What I believe is going on is that the device is placed in a programming mode briefly when you try to upload and is looking for a makey makey device. Sorry for the long explanation, just trying to make it easy for everyone. Let me know if this worked for anyone.
     Good Luck!

    They had to press the "upload" a few more times but it finally worked after following those tips from the other customer. A customer that I was helping had the same issue where it was a board from JoyLabz and they kept clicking upload and it finally worked.

    Compile Error

    If you see this error:

    'KEY_UP_ARROW' was not declared in this scope

    It's possible that you did not select the correct board definition. Make sure that you are selecting the correct board definition. This guide should provide you with information about installing the board add on [ ]. If you do not have "SparkFun Makey Makey" selected, it will have issues compiling because it is not able to understand certain variables defined for the Atmega32U4.

    • Member #671545 / about 9 years ago / 1

      help me... i buy from sparkfun but still cannot upload the sketch

      • There is a new file structure with the Arduino IDE v1.6+. Make sure that you download the new board definitions and select the "SparkFun Makey Makey" for Arduino IDE v1.6+ in order to compile and upload code.

      • Please contact techsupport@sparkfun dot com and they should be able to help you troubleshoot this.

  • Member #612861 / about 10 years ago / 1

    I installed driver and all process goes well... except save. I have an error and that is like this: Third-party platform.txt does not define compiler.path. Please report this to the third-party hardware maintainer. at at at at at at at$ at Source) Caused by: java.lang.NullPointerException at at at at ... 7 more

    and there is a yellow line at the first line file name makey makey 1 4 1 (I think that's the error mark) the first line is just : /* what should I do?

  • Member #484834 / about 10 years ago / 1

    Upate you have to download Arduino 1.0.5. With the newer ones it does not work.

  • Member #484834 / about 10 years ago / 1

    i installed the addon but cant see the makey makey board ...

If you've found an issue with this tutorial content, please send us your feedback!