Comments: Arduino Weather Shield Hookup Guide V12


Looking for answers to technical questions?

We welcome your comments and suggestions below. However, if you are looking for solutions to technical questions please see our Technical Assistance page.

  • Member #1582757 / about 4 years ago / 1

    I would like to ask about the GPS module-GP735 hook up, I tried to connect it with the shield by following the same procedure Sparkfun gave me and the data of Long, Lat, Att, Date, still show 0.000; 0.000; 0.000 and 00/00/2000, Which mean it has not received the data from the satellite. I brought the entire system outside and let the GPS has the best view of the sky, but still nothing change. Can anyone help me to fix it?

    • santaimpersonator / about 4 years ago / 1

      Hi there, it sounds like you are looking for technical assistance. Please use the link in the banner above, to get started with posting a topic in our forums. Our technical support team will do their best to assist you.

  • Member #152222 / about 6 years ago / 1

    I should also mention I ran into an issue with the weather shield onboard temp sensor reporting about 6 or 7 degrees higher than it should after the weather shield warms up from the Redboard mounted below it.

    To fix this I've added an Adafruit MCP9808 precision I2C temp sensor. This allows me to put the Redboard, Weather Shield and XBee Shield in a sealed box. The MCP9808 sensor is in a separate solar shield and connects to the Redboard stack through 18 inch wires. I plan to do the same thing with a humidity sensor.

  • Member #152222 / about 6 years ago * / 1

    I'm in the process of setting up the Weather Shield with a WeatherRack and discovered the bug mentioned below about windspeedmph always showing 0.0. I believe I have a fix for it. In the main loop:

    float currentSpeed = get_wind_speed();

    windspeedmph = currentSpeed; //add this new statement

    I'm using a Sparkfun RedBoard (DEV-13975) and Sparkfun XBee Shield (WRL-12847) with the Weather Shield, which communicates with a 2nd XBee connected to a Raspberry Pi.

    The Pi logs the weather data to its hard drive and also FTP's it to a host web page.

    • EdZilla / about 5 years ago / 1

      You have a fix? It would be good if you did a pull request and corrected it. However, the github repository is a real mess.

      • EdZilla / about 5 years ago / 1

        windspeedmph = currentSpeed; //add this new statement I see issue reported in github and the fix. Thanks!

  • Member #550548 / about 7 years ago / 1

    Any fix to windspeedmph only showing 0.0

  • Member #994345 / about 7 years ago * / 1

    Hello. I'm using the Weather Shield (last release) with an Arduino M0 and the recommended codes, but I can not get valid values for the measurements. I tried using the sheild in an Arduino UNO and everything goes well, but with Arduino M0 I'm getting something like (PS: I'm using the last version of Arduino IDE and i tried in previous versions too):

    Humidity = -5.81%, temp_h = -46.58F, Pressure = -999.00Pa, temp_p = -1766.20F

    Tanks, André

    • atkulp / about 6 years ago / 1

      I hate responding to a post from eight months ago, and I'm a bit disheartened by the lack of response, but... I'm experiencing the exact same issue. In my case, I'm connecting it to a Nano and bridging pins between the Nano and Weather Shield. I have the SDA, SCL connected to the matching pins on the Nano, and I've connected Batt level (2) and light (1) to two analog pins (using LIGHT and BATT constants). I've also connected 3V3 directly to another analog pin on the Nano and specified the pin number as REFERENCE_3V3. For good measure, I connected GND of the Nano to a GND on the Weather Shield. No errors, but my output matches parent post: all negative numbers, nearly identical. HELP!

  • Member #267471 / about 7 years ago / 1

    Hi. I noticed that the analog input lines do not work properly when this shield is in place. I have the older weather shield without the temperature sensor, so I'm using the TMP36 temperature sensor along side it using one of the analog in pins. I tried all the pins and the voltages reported are incorrect. This is not an issue without the weather shield. Are all the analog pins used by the shield?

    • CF / about 7 years ago / 1

      analog input lines do not work properly when this shield is in place.

      This shield uses all six of the Arduino's analog pins for shield functions already. If you don't need wind direction and modify the code, you could free up A0 for your own use.

      • Member #267471 / about 7 years ago / 1

        Yes, thank you for the response. I looked at the schematics and indeed all the analog pins are used. I do need wind direction, so I'm going to switch to a one wire temperature sensor instead (DS18B20) and use one of the free digital pins instead. This should solve my issue.

  • Member #911471 / about 7 years ago / 1

    "SparkFun Si7021" does not seem to be available from the Library Manager. The code is at GitHub, but I'm not sure how to download and install from there. The Library Manager works great for other libraries, so would be best solution.

    thanks Richard

    • Member #267471 / about 7 years ago / 1

      Download the cpp and h files from the GitHub site and save them in a new folder in the Documents\Arduino\libraries folder. You should be all set and the library will show up in the library manager as installed.

If you've found an issue with this tutorial content, please send us your feedback!