Comments: RedBoard Hookup Guide

Pages

Comments 5 comments

  • I have essentially the same problem with my RedBoard as Jim. I have the correct serial port in the Tools menu of the Arduino software, and the board executes the default “Blink” program when plugged in, but uploading yields:

    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
    

    I am running OS X Sierra. Any advice? I’ve already tried all of the tips regarding FTDI Drivers on this page.

    • That is a standard error for “I can’t find the bootloader I’m looking for”. That might mean you have the wrong board selected, the wrong port selected, incorrect drivers installed. If you are still having problems please send a screen shot of the error to techsupport@sparkfun.com and they should be able to help you out.

  • I have a RedBoard that someone from Sparkfun gave my son at a conference in Austin. I can’t upload any sketches to it.

    I’ve got serial port connectivity to it on both OS X and FreeBSD, at least, I have connectivity enough to make the ‘TX’ LED light with each keystroke.

    but if I try to use the Arduino software (using the blink example), I get:

    “Binary sketch size: 1,084 bytes (of a 32,256 byte maximum) avrdude: stk500_recv(): programmer is not responding”

    I’ve never seen a response (of any type) from the board. I would think that the boot loader (if present) would respond to, say, a simple carriage return.

    From ‘cu’, I’ve tried the following baud rates: 4800, 9600, 19200, 38400, 57600, 115200.

    None have succeeded.

    I believe I have the correct drivers. When the RedBoard is plugged in, dmesg reports:

    AppleUSBFTDI, fInBufPool,kMaxInBufPool 8,64 0 [Level 5] [com.apple.message.domain com.apple.commssw.ftdi.device] [com.apple.message.signature AppleUSBFTDI] [com.apple.message.signature2 0x403] [com.apple.message.signature3 0x6001] [com.apple.message.summarize YES] AppleUSBFTDI: Version number - 1.0.1b10, Input buffers 8, Output buffers 16

    and I get two device entries: /dev/tty.usbserial-AM01VDPE /dev/cu.usbserial-AM01VDPE

    both are mode 666 (crw-rw-rw), so it’s not a permissions problem.

    Powering the board on blinks the blue LED (marked ‘13’) three times.

    Help?

    • Weird. As long as you’re selecting the correct board in Arduino (“Arduino Uno”), it sounds like you’ve got everything else set up correctly. Maybe it’s a bad board? I’d recommend contacting tech support, they could help you out further.


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!