Comments: Programming the Intel® Edison: Beyond the Arduino IDE

Pages

Comments 17 comments

  • ——————– Tech Support Tips/Troubleshooting/Common Issues ——————–

    Intel® System Studio IoT Edition: Troubleshooting and FAQ

    [ https://software.intel.com/en-us/node/594235 ]

  • Hello, Could you expand on the super important note for Windows Users. I’m not familiar with how to make those changes.

    Thank you, Jordan

    • Sure! In the file that you download and extract there’s a file called “devkit-launcher.bat”. This is a script file that runs a number of commands launching eclipse with all the proper settings you’ll need to for it to work for the Edison.

      That file isn’t really a program, it’s just a text file with a different extension. You can open it from within any text editor (WordPad, which comes with Windows, is probably the best option), and then change the lines indicated in the tutorial.

      • Unfortunately making that change didn’t help me. I get this error:

        Error - Required Java version 1.8 or higher not found. Please install Java JRE 64 bit 1.8 or higher from http://wworacle.com/technetwork/java/javase/downloads/index.html in order to launch the Intel® IoT Developer Kit. If you wish to develop Intel Iot Projects with Java then please install Java JDK 64 bit 1.8 or higher which includes Java JRE and ensure Java is in Path. I created a system variable: PATH with value C:\Program Files\Java\jdk1.8.0_65 which is the path to where I installed Java. I have a 64 bit computer. If you have any idea what’s going wrong I would greatly appreciate any help. Thank you, Jordan

        • I’m afraid I don’t, other than to suggest maybe adding subdirectories to the path variable?

          I’ll say this: I have only jre7 on my machine, and I’ve been able to run this SDK with no trouble. Although I haven’t tried in a few weeks.

          • I just uninstalled all of my versions of Java and reinstalled the JDK and Java and made the correction you suggested. Everything works now! Thank you very much for posting this.

  • Hello! My name is Reagan! I’m 13 and I’m having some trouble with copying files in Eclipse. I’m making a smartwatch with the Intel Edison and I’m trying to install a graphics driver for a touchscreen I got. When I copy 2_ccp_helloworld and delete the helloworld programs and replace them with the files I have and build the project, one of the 4 files will have an x by it…I’m not sure what to do. By the way I’m just learning Edison and Eclipse from your tutorials! Thank you!

    • Usually, that means Eclipse can’t find the file in question.

      Generally, a Google search on the specific text of the error message will find an answer, or at least give you an idea of where you should start looking.

      • Thanks for the help! I put my files into a existing working project(2_cpp_helloworld) and I ran and built the file. I think it downloaded on to the Edison but I got this in the console:

        edison@ubilinux:~$ chmod 755 /tmp/graphicsTest;/tmp/graphicsTest;exit /tmp/graphicsTest: line 1: /bin: Is a directory /tmp/graphicsTest: line 2: This: command not found /tmp/graphicsTest: line 3: http://www.adafruit.com/products/1651: No such file or directory /tmp/graphicsTest: line 5: Check: command not found /tmp/graphicsTest: line 6: These: command not found /tmp/graphicsTest: line 7: syntax error near unexpected token RST' /tmp/graphicsTest: line 7: interface (RST is optional)‘ logout

        Is it just that it is thinking the comments are commands or is it something deeper? Thank you!

  • It’s possible to use this IDE with ublinux or just yocto ?

    Thanks

    • I don’t know, for sure. I don’t know what it uses under the hood to transfer the files. If I were making a system like this I’d probably use rsync, which would be fairly easy to add to the Edison with Ubilinux.

      Pure speculation. I’d say, try it and see!

  • This is a noob question but what is the difference between loading up the Intel XDK Intel Edison IoT and setting up Eclipse as described above? What are the Pros and Cons of each? I haven’t loaded either yet rather just doing some simple command line code. Is the Intel XDK buggy or incomplete? Thank you.

    By the way these tutorials are great for someone getting started. The hardest thing is having all this energy and enthusiasm to start creating something great and then you get stuck right at the beginning with a problem not loading the right driver or such. These tutorials help you get through that and make it easier for all of us. So BIG thanks.

    • Maybe someone else will answer, but I’ll say that I haven’t used the XDK at all. AIUI, the XDK is aimed at forward-facing applications: XDK apps are more web-pagey, and use Javascript rather than C++.

      So, I’d say that it’s really on you: which are you more comfortable with, Javascript or C++? If you are equally comfortable with both, there are probably things best done in one or the other, but if you’re way more comfortable with one of those languages, you’ll probably find it easier to use the one you’re familiar with.

      • Thank you for the quick response.

        There was a comment in the tutorial: “In later tutorials, we’ll cover Python, JavaScript, and other options for getting the Edison to do what you want.” So will the IDE for Javascript then be the XDK or will you stay with the Eclipse IDE?


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!