Comments: SparkFun Blocks for Intel® Edison - UART Block

Pages

Comments 13 comments

  • I am a bit confused with the switch on this UART block. When we shift the switch to UART1, is that equal to Serial1 in the Arduino sketches?

    I got this block to interface with my Serial GPS device and connecting the 4 pins Ground, Vin, Tx & Rx. No luck yet :(

  • Hi, We bought a UART board and base board. I try to use mraa lib to inital the uart1(/dev/ttyFMD1 ?). But it fails. Could you provides me some startup code example for UART to working?

    I user configure_edison –version. It reply 120.

  • I bought one of these along with the Edison. I did not buy the base or the console, so I haven’t gotten onto the board or upgraded it or anything. Following the instructions and connecting at 115200 with my trusty 5V FTDI cable (https://www.sparkfun.com/products/9718) produces nothing but garbage. Doesn’t seem to matter what speed I connect at – just noise over the line.

    What am I missing?

    • Is the switch selected to console?

        • You are right, It looks like our FTDI cable isn’t sourcing enough current to get past initial boot. I have tested this with out FTDI Basic again and I can boot no problem. I’ll continue digging. In the meantime I will remove the bad info from the tutorial. Thank you for finding this!

          • Glad I could help! So, what are my options? Source power from elsewhere? Why am I getting anything over the line if I can’t get past initial boot, and why is it garbage?

            • I tried external power sources and it doesn’t seem to help much. For now it looks like our FTDI Basic is the only device that works. I’ll keep working on it. The garbage seems to be noise. My guess is the logic levels are not quite right or there is simply noise on the signals. It is strange for sure.

              • Like Myles I have the same problem using the FTDI 5V cable. I suppose the FTDI cable do power the EDISON ok since I’m able to connect to it over WIFI. (I previously installed Ubilinux on the EDISON using Arduino Edison breakout board).To bad the UART block don’t work… was hoping to read serial data from external device. please help…

                • I also tried external power sources with no luck. I noticed wrong signal level using the scope. The Edison Tx is only 2.48 v. I suppose that explain the garbages that we receive. Could the problem be related to pull up resistors on target? I read this regarding the TXB0104 on SF Volatge-Level-Translator-Breakout. “….resistors on the target device. The value of the pull-up resistors was too low, which caused the IC to be confused about the direction of the signals.”… hope it helps. Thanks SparkFun.

        • Hmmm…. let me see if I can’t replicate the problem here.

  • Is it possible to stack multiple UART Blocks so that I can connect more than one (something like 4) device to my edison?


If you've found a bug or have other constructive feedback for our tutorial authors, please send us your feedback!